[GRASS-dev] [EXTERNAL] [GRASS GIS] #3560: r.in.lidar: error to open valid LAZ file

Newcomb, Doug doug_newcomb at fws.gov
Wed May 9 12:37:27 PDT 2018


On Wed, May 9, 2018 at 3:21 PM, Markus Neteler <neteler at osgeo.org> wrote:

> Doug,
>
> On Wed, May 9, 2018 at 9:17 PM, Newcomb, Doug <doug_newcomb at fws.gov>
> wrote:
> > Markus,
> > Liblas reads LAS version 1.2 , which is limited to 4.2 billion points.
>
> I see. But "count" states 297.683.873 which is way less points?
>
Good question


>
> > You have to compile liblas with an older version of laszip .
>
> Uhm, why an _older_ version?
>

The API to LASzip changed with version 3.   I use LASzip 2.2.0 compiled
with liblas from 2013 and have no problems so far.   https://laszip.org/
The most recent version of 3  was for version 1.4 of the LAS spec.

You need to compile current pdal and current  liblas with different
versions of the Laszip library .


> thanks
> Markus
>
>
pdal used to output version 1.2 of las data by default . I t worked fine
for me at version 1.6 . I have not checked if that is the case with version
1.7.1 .  1.7 had a bug which required a quick bugfix to 1.7.1, by the way.
( I do not recall the bug off of the top of my head.)




Doug




-- 
Doug Newcomb
USFWS
551F Pylon Dr
Raleigh, NC
919-856-4520 ext. 14 doug_newcomb at fws.gov
---------------------------------------------------------------------------------------------------------

*NOTE: This email correspondence and any attachments to and from this
sender is subject to the Freedom of Information Act (FOIA) and may be
disclosed to third parties.*‚Äč
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20180509/607c5463/attachment.html>


More information about the grass-dev mailing list