[GRASS-dev] Package grass installed by pip is not GRASS GIS

Vaclav Petras wenzeslaus at gmail.com
Wed Oct 10 06:56:30 PDT 2018

[was:[GRASS-user] Using grass.script in Jupyter (Azure)]

Dear all,

in less than two days, I have seen two users reporting "I have successfully
installed GRASS using pip" (see e.g. the post to the grass-user list below,

It is an an unfortunate situation because there is a package called `grass`
unrelated to GRASS GIS project. See:


The package installs a executable called `grass` and of course a Python
package called grass. See also:


What do you think would be the best course of action?


On Wed, Oct 10, 2018 at 5:18 AM Markus Neteler <neteler at osgeo.org> wrote:
> Hi,
> Mehrdad Varedi <varedi at gmail.com> schrieb am Mi., 10. Okt. 2018, 03:25:
>> Hi Everyone,
>> I want to develop a program using GRASS python libraries in Jupyter(on
Azure). All codes begin with:
>> import grass.script as gscript
>> of course the grass.script is not available in Jupyter. I tried to
install GRASS
>> I used: !pip install GRASS
>> and it worked like a charm, although I can't have access to grass.script.
>> Sorry if it is a silly question, although I apreciate any idea to begin
programming GRASS on Azure.
> Please check the Jupyter examples here:
> https://grasswiki.osgeo.org/wiki/GRASS_GIS_Jupyter_notebooks
> They may give you a start. Please let us know how it goes and feel free
to add your notes to the wiki page.
> Best,
> Markus
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20181010/7ac8ad28/attachment-0001.html>

More information about the grass-dev mailing list