[GRASS-dev] FIXED: Re: compiling GRASS-latest - configure fails with Unable to locate PostgreSQL includes

Zoltan zoltans at geograph.co.za
Mon Jun 21 07:08:59 PDT 2021

Hi Markus,
OK, I am now logged into the Ubuntu system I used, and can better trace 
what I did.

I started my research at 
Under "Prerequisite/Installation order" I installed/compiled gdal with 
ecw, and installed postgres.

I then did a ./configure (without extra parameters) and tried to bumble 
my way through the errors I was getting.
I fired off my initial email to grass-dev as I was not finding the solution.

I then found the grass-wiki recipe and corrected the problems by 
copy/paste the ./configure for Ubuntu 20.04

So, a few thoughts from my side.

  * In the github install (all versions of grass), add a pointer to the
    grasswiki page, especially at the ./configure paragraph. (I would
    find it more reliable and easy to manage a link to one source of
    info, than to copy the source into contents of other documents)
  * Amend the configure script error message to suggest the that the
    with-XXX-includes= parameter should be used, instead of just:
    configure: error: *** Unable to locate FreeType includes.
  * As most apt installed products go to specific directories, is it
    possible to let the configure script not first try a few obvious
    places before crashing with the error message? If they are not 'apt
    installed', then they likely go to /usr/*local/*XXX

HTH, and thanks again for your persistence.

On 2021/06/21 13:32, Markus Neteler wrote:
> Hi Zoltan,
> Where would you expect this info, i.e. a link to the wiki?
> Maybe we can improve things :)
> Best
> Markus
> Zoltan <zoltans at geograph.co.za <mailto:zoltans at geograph.co.za>> 
> schrieb am Mo., 21. Juni 2021, 12:11:
>     Hi Markus/Māris,
>     Thanks for your interest.
>     @Māris:  I did provide the log tail-end on my first post.
>     @Markus: I started off the process using Google/Duck-Duck-Go to
>     piece together what info I needed, as I wanted ECW support and one
>     or two other add-ons.
>     Far too many websites offering help, come up.
>     I read through a couple but only later the Grasswiki you referred
>     to below - and then only noticing the with-XXX-includes folder
>     directives.
>     my bad :-(
>     Regards and keep well,
>     Zoltan
>     *On 2021-06-21 07:20, Maris Nartiss wrote:*
>>     Please include relevant part of configure.log where exact reasons of
>>     failure will be seen.
>>     Māris.
>     *On 2021-06-20 18:42, Markus Neteler wrote:*
>>     Hi Zoltan,
>>     On Sat, Jun 19, 2021 at 12:36 PM Zoltan<zoltans at geograph.co.za>  <mailto:zoltans at geograph.co.za>  wrote:
>>>     Hi Devs,
>>>     Sorted!
>>>     The correct folder(s) were:  -with-postgres-includes=/usr/include/postgresql --with-freetype-includes=/usr/include/freetype2
>>>     (Had to add the freetype include folder as well)
>>     Glad you solved it.
>>     BTW, there is a wiki page with hints:
>>     https://grasswiki.osgeo.org/wiki/Compile_and_Install_Ubuntu#Quick_instructions  <https://grasswiki.osgeo.org/wiki/Compile_and_Install_Ubuntu#Quick_instructions>
>>     Please feel free to improve it as needed.
>>     Best
>>     Markus
>     -- 
>     =============================================
>     Zoltan Szecsei GPrGISc 0031
>     Geograph (Pty) Ltd.
>     GIS and Photogrammetric Services
>     Cape Town, South Africa.
>     Mobile: +27-83-6004028 (Signal, not WhatsApp)
>     www.geograph.co.za  <http://www.geograph.co.za>
>     =============================================

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-dev/attachments/20210621/1524efff/attachment.html>

More information about the grass-dev mailing list