m.dem.extract woes

Michael Shapiro shapiro at zorro.cecer.army.mil
Fri Jun 5 09:40:43 EDT 1992

The version of m.dem.extract released with grass4.0 had some bugs in
it.  There is a a fix on moon.cecer.army.mil. Get that version and let
me know if you still have problems. We have a newer version which we
will be putting on the ftp site is a few days. I'll announce it when it
is ready. If that version still has problems then you should send me your
data and we'll use that to debug the program further.

| I'm still getting errors from get_int and get_float when I run d.dem.extract.
| The machine I am running on is a SUN SPARC II.  I ran m.dem.examine and
|my coordinate system is UTM and fits within the window.
| The get_int and get_float errors occur after reading the DEM for the
|14th 7.5 minute quadrangle (GREENS CREEK).  When I run a m.dem.examine, the
|output of the 14th quad is followed by additional files.  For example:
|min. elevation 589.000000 max. elevation: 1503.000000
|ns_res:0.000000 ew_res:0.000000
|# of columns in file = 809773872
|File north UTM = 3917021.5000
|File South UTM = "a number"
|FIle east  UTM = "a number"
|File west  UTM = "a number"
|DILLARD, GA-NC            1988
|min elevation: -Inf max elevation: -Inf
|ns_res:-Inf ew_res:-Inf
|# of columns in file = 0
|File north UTM = 0.000000
|File south UTM = 9999999.000
|File east  UTM = 0.000000
|File west  UTM = 9999999.000
| The Dillard quad was read in already (and looked similar to the
|standard output as GREENS CREEK above.  But after Greens Creek, Dillard
|shows up again as above.  
| Could these additional files be part of my problem?  When I ran a
|m.tape.examine these additional files also had a different blocksize.
| Also why are'nt the quads that appear to be run successfully written
|out to a file?
|Richard Flamm


More information about the grass-user mailing list