Trouble w/ Solaris d.mon

Jim Pirzyk pirzyk at
Thu Jul 14 18:58:10 EDT 1994

In info.grass.user you write:


>I just successfully (well, almost) installed the compiled binaries for 
>Solaris2.x from moon.  However, when I try

>d.mon start=x0

>I get the following error message:

> x0: fatal: can't open file: errno=2
>Error - Can't set up pipe to graphics device.
>Problem selecting x0. Will try once more
>Error - Can't set up pipe to graphics device.

>I have located on my machine in /usr/lib.  I cannot find,
>the closest I find is in /usr/4lib.  I have tried setting the
>environment variable LD_LIBRARY_PATH to both /usr/lib and /usr/4lib and still
>get the error.  I have tried copying to, but that
>did not work, as I expected.  I tried copying both and
>to LD_LIBRARY_PATH, but that does not work.  

Try adding /usr/openwin/lib to LD_LIBRARY_PATH, that is where* are
usually stored.

- Jim Pirzyk
[Jim] pirzyk at -------------------------------------------      __o
TAC & GrassNet System Administrator, US Army Corps of Engineers      _'\<,_
Construction Engineering Research Laboratories, Champaign IL USA    (*)/ (*)

More information about the grass-user mailing list