Trouble w/ Solaris d.mon

Steve Dzurenko steve at ocesun1.oce.uri.EDU
Thu Jul 14 17:49:49 EDT 1994


I just successfully (well, almost) installed the compiled binaries for 
Solaris2.x from moon.  However, when I try

d.mon start=x0

I get the following error message: x0: fatal: can't open file: errno=2
Error - Can't set up pipe to graphics device.
Problem selecting x0. Will try once more
Error - Can't set up pipe to graphics device.

I have located on my machine in /usr/lib.  I cannot find,
the closest I find is in /usr/4lib.  I have tried setting the
environment variable LD_LIBRARY_PATH to both /usr/lib and /usr/4lib and still
get the error.  I have tried copying to, but that
did not work, as I expected.  I tried copying both and
to LD_LIBRARY_PATH, but that does not work.  

What is the library that is being looked for and does anyone know how I can 
solve this problem?

-Stephen Dzurenko
 Ocean Mapping Division
 Ocean Technology Center 
 Graduate School of Oceanography
 University of Rhode Island

 ph: 401 792-6853
 fx: 401 792-6849
 e-mail: steve at

More information about the grass-user mailing list