r.mapcalc's gone cranky - HELP !!!

Alastair Duncan 100074.213 at compuserve.com
Wed May 31 08:00:00 EDT 1995

Hello Everyone,

I have just come across a really frustrating problem using r.mapcalc that I
don't understand. I've just upgraded to the floating point / null data version
of GRASSv4.1.5 that Olga put on the moon recently - with everthing running
smoothly until I tried the following r.mapcalc calculation :-

mapcalc> map_d = ( (map_a / map_a) + (map_b / map_b) + (map_c / map_c) )

My version r.mapcalc does not seem to be able to add up anymore !!!! The
resulting map_d from the above equation contains no data - even though map_a,
map_b and map_c all contain data of between 1 and 100 - and also eventhough
doing the divisions in the brackets individually worked, adding together the
resulting maps resulted in an empty map again !!!!
There is no MASK file. 

Am I missing something absurdly simple ??? Or has my r.mapcalc really gone
screwy ??? Surely there must be an easy solution - has anyone got one ???

Cheers, Al.

More information about the grass-user mailing list