lost GRASS graphics monitors....

neil at eng-h.gov.uk neil at eng-h.gov.uk
Wed Dec 18 12:25:39 EST 1996


Hi GRASS users,

I am a very new GRASS user running grass4.1 under SOLARIS_2.3.

Any answers to the following problem would be very welcome indeed....

Please let me have a DIRECT RESPONSE to n.linford at eng-h.gov.uk

Many thanks


I had GRASS up and running quite nicely... and then my graphics
monitor packed up due to operator error with the "d.zoom" command.

I lost control of the monitor and tried the following:

"d.mon stop=name " - this reported a "couldn't select graphics window error

"kill -9 GRAPHICS_WINDOW_ID#" - this got rid of the pesky window but...

"d.mon -L" - keeps crashing even after exiting and re-starting GRASS.

I tried all of the FAQ "bad exit" tips, ie

removed "$GISBASE/locks/my_machine"

removed ".gislocks"

a "ps -ef" revealed no processes running the monitors.

Every time I log into GRASS and run "d.mon -L" a new lock file
with a lock in it is created and I can't get control of the
monitor back... or a X-Window on the screen.....

Any ideas for solution VERY welcome indeed....

Best regards and thanks for your time,

Neil Linford


More information about the grass-user mailing list