Can't run d.mon

Malcolm Williamson malcolm at
Mon Oct 21 08:00:00 EDT 1996

Hi, Luc
Could you be running a video mode with more than 256 colors?
Malcolm D. Williamson - GIS Specialist           E-mail: malcolm at
Center for Advanced Spatial Technologies      Telephone: (501) 575-6159
Ozark Rm. 12                                        Fax: (501) 575-5218 
University of Arkansas              
Fayetteville, AR 72701

On Mon, 21 Oct 
1996, Luc Boerboom wrote:

> Hello GRASS-users,
> I look forward to the time that I can answer questions but for now I
> still only ask them. I reinstalled GRASS on a Linux 2.0.0 PC with a
> new videocard (Diamond Stealth 64 2MB) after my harddrive had broken
> down and was replaced. GRASS worked under the old configuration with the
> only differencethat it ran on the old harddrive and a Diamond Speedstar
> 1MB card. Obviously I had to reconfigure my windows configuration file:
> XF86Config, a Linux file.
> I installed the 1996 Linux compiled linuxg.a* files with the
> The problem:
> I can start GRASS just fine and after filling out the entry screen I get
> the GRASS prompt. Running e.g. d.rast works fine until it complains (of
> course) that I need to run d.mon.
> When I run d.mon this is what happens:
> GRASS-GRID > d.mon start=x3
> X Error of failed request:  BadMatch (invalid parameter attributes)
>   Major opcode of failed request:  78 (X_CreateColormap)
>   Serial number of failed request:  75
>   Current serial number in output stream:  76
> Please start graphics monitor <x3>.
> Error - Graphics monitor <x3> not running!
> Problem selecting x3. Will try once more
> Please start graphics monitor <x3>.
> Error - Graphics monitor <x3> not running!
> I tried:
> - csh and bash (the latter worked before hardrive brake down)
> - fvwm95 and fvwm (the latter worked before hardrive brake down)
> - to install Grass4.1.3 which for some reason did not work, I guess it
>   was confused with the other GRASS4.1.5 still being present.
> A suggestion here at computer services was that I might want to recompile
> GRASS on my own machine. Is that a solution? What does it entail? Where is
> thes source code located of GRASS 4.1.5? (I think i did see 4.1.3)?
> ORRR... is this not a GRASS problem but an X-windows or Linux problem?
> I hope All this info is enough for one of you to help me out. Thanks in
> advance.
> Luc

More information about the grass-user mailing list