SunOS 4.1.3 binaries & Solaris 2.5.1

Angus Carr apcarr at flash.Lakeheadu.Ca
Wed Apr 2 15:44:02 EST 1997

I have had some difficulties running GRASS on Solaris, too. These I solved
with a bit of play with the binaries.

I d/l'd the Solaris binaries, and installed them (my third architecture
now for GRASS binaries, and the most cantankerous (sp?) by far.) under
Solaris 2.5.1.

Whenever programs haven't worked (notably XDRIVER), I have had success
with copying over the SunOS 4.1.3 binary of the program from another
machine that runs it under SunOS 4.1.1

Between that and permissions and NFS not working between machines, It has
been entertaining.

To this day (3 months later) I still hang the Solaris machine running
GRASS, although I suspect that there is a hardware problem causing the

Good Luck, and if you need some help, drop a note.

Angus Carr
Masters of Forestry student

On Wed, 2 Apr 1997, William L. Baker wrote:

> Trying to get SunOS 4.1.3 GRASS binaries working
> under Solaris 2.5.1, since an earlier message suggested
> this might be easier than compiling GRASS source.
> When starting GRASS the script has problems
> with ~/etc/lock and ~/etc/gis_set, then has problems
> with g.gisenv.  Error messages are hard to understand,
> but clearly has problems with these.
> Any idea what's wrong?
> Bill

More information about the grass-user mailing list