importing a .lan

Angus Carr apcarr at FLASH.LakeheadU.CA
Thu Mar 6 12:13:58 EST 1997

You have run into the infamous byte-order problem, I suspect.
GRASS's fails to check for byte-order when it imports erdas
files. This caused me a problem testing my i.out.erdas program. I ended up
adding a switch to the command line to switch byte order.

I don't really have a solution directly, but I can make a suggestion if
you don't mind getting a little code under your fingernails. The
i.out.erdas filter to which I refer has a complete format spec in it for
the ERDAS format. You could read in the erdas header as an erdas_h type
(see my code) switch around the order of the bytes (again, a simple
function in that code) and spit it back out. You could even convince me to
do it for you, but I am a little busy right now. It could even make it
no-longer BIP format, but the more conventional BIL format, but that might
actually require effort. 

The code to which I refer is at
I should warn you about the filter it compiles- it drops the geocoding.
Someday, I will fix it...

Angus Carr.

On Wed, 5 Mar 1997, J. HOLLENBECK wrote:

> Hello all,
> 	I want to thank those individuals who answered my question
> regarding my HP deskjet and grass....but now I have a much larger problem.
> I have a satellite scene in the form of a .lan file.  The .lan was not
> produced by ERDAS and I am told that it is in BIP (band interleaved by
> pixel) format.  I can read and view this file in ArcView2 with no problems
> but cannot for the life of me, get it into GRASS.  I have tried
> and I get bizarre values in the header report and then a "Memory
> Allocation Error".  I have tried i.tape.other but it only supports BIL and
> BSQ formats.  If anybody has *any* suggestions, I would love to hear from
> you.
> Thanks in advance.
> Jeff Hollenbeck
> Dept. of Fishery and Wildlife Science
> New Mexico State University
> jhollenb at

More information about the grass-user mailing list