problem with d.mon

Antonio Rodriguez Verdugo rod.chav at
Sun Apr 5 10:01:36 EDT 1998

At 09:29 PM 3/04/98 +0200, you wrote:
>I have a problem with graphics monitor.
>I recently have changed motherboard and video card and installed a new
version of Xfree86 (3.3.2 on linux 2.0.29, Slackware 3.2). Grass4.1 starts
without problems but graphics monitor doesn't work. When I run d.mon
start=x0, it gives me the following message: 
>X Error of failed request: Badmatch (invalid parameter attributes)
>   Major opcode of failed request: 78 (X_CreateColormap) 
>   Serial number of failed request: 78 
>   Current serial number in output stream: 79 
>Please start graphics monitor <x0> 
>Error - Graphics monitor <x0> not running! 
>Problem selecting x0. will try once more.. 
>I've tried to install grass again but with the same results. 
>Any help appreciated. 

Dear Valerio,

I've had the same problem some time ago. I solved the problem, selecting
(during RedHat linux installation) the 8 bit video mode. I hope this helps

Antonio Rodríguez-Verdugo
Sevilla, Spain

More information about the grass-user mailing list