Compiling 4.2.1 on Solaris?

Jan Nicolai Langfeldt j.n.langfeldt at
Wed Apr 22 08:08:10 EDT 1998


have anyone tried to compile 4.2.1 on solaris?  I'm having a problem
in src421/src.alpha/raster/r.hdf/HDF_lib/src where a lot of make
variables seem to be undefined, foremost of them is CC and MACHINE.  I
tried hardcoding the variable values, but the only thing that worked
was hardcoding CC and CFLAGS in the compilation rules.  That make
compilation work at least, but when installing:

ar r libdf.a hfile.o herr.o hblocks.o hextelt.o hkit.o dfan.o dfr8.o dfcomp.o  dfimcomp.o dfp.o dfgr.o df24.o dfsd.o dfgroup.o dfconv.o dfufp2i.o   vg.o vrw.o vio.o vparse.o vconv.o vsfld.o vgp.o vhi.o      dfutil.o dfstubs.o
ar: creating libdf.a
ranlib libdf.a
mkdir /mn/isfjord/local/ttmp/src421/src.alpha/raster/r.hdf/HDF_lib/include
mkdir: Failed to make directory "/mn/isfjord/local/ttmp/src421/src.alpha/raster/r.hdf/HDF_lib/include"; File exists
*** Error code 2 (ignored)
cp hfile.h hdf.h hdfi.h herr.h hproto.h dfan.h dfrig.h dfgr.h dfsd.h  dfgroup.h dfconvrt.h vg.h df.h dfi.h dfstubs.h dfufp2i.h vproto.h /mn/isfjord/local/ttmp/src421/src.alpha/raster/r.hdf/HDF_lib/include
mkdir: usage: mkdir [-m mode] [-p] dirname ...
*** Error code 2 (ignored)
cp libdf.a 
cp: Insufficient arguments (1)
Usage: cp [-f] [-i] [-p] f1 f2
       cp [-f] [-i] [-p] f1 ... fn d1
       cp -r|R [-f] [-i] [-p] d1 ... dn-1 dn
*** Error code 2 (ignored)
ranlib /libdf.a

the directory name variables are undefined at the point where the
install_it target is executed...  Using gnu make (3.76.1) does not
change anything.

I was unable to determine what went wrong to make behave this way.

Does anyone have any hints?


More information about the grass-user mailing list