Grass and glibc6

Michael Schulz schulzm at
Fri Dec 11 05:46:52 EST 1998

On Tue, 8 Dec 1998, Adalberto da Silva wrote: 

> > As I'm putting another machine to run I'm trying to install Grass  *and*
> > Debian 2.0 because there are some good programs using libc6. 

> > But when I tried to run Grass under X I just got this message:

> > "/usr/local/grass42/etc/ line 47: 2560    segmentation fault
> > $ETC/gis_set"

> > If I run Grass from a 'normal' terminal it works (and it works well I
> > must point out!) but... Well, anyone wants a good and coloured screen
> > filled with those colourful maps...

> Adalberto da Silva

Hello Adalberto !

We had the same problem on one of our machines. By default, Debian uses a
special xterm (Debian-xterm), which seemed to cause the problem we had
(same segmentation fault).

Try using the "standard xterm" (information about that in
/usr/doc/X11/README-Debian). Hope this helps !

Michael Schulz 
Geologisches Institut 
Universität Freiburg

mschulz at

More information about the grass-user mailing list