tcltkgrass errors

arch. Stefano Maffulli stefano.maffulli at DPMPE.UNIFI.IT
Fri Jul 30 10:02:37 EDT 1999

Hello all
I managed to setup grass on a SPARCstation 20 running solaris2.6 and
CDE.  Grass works fine (I am going through the ASSIST tutorial) but I
get errors when trying to run the tcltkgrass.  
I installed the grass4.21 bin21 for solaris2.6, did not compile by
The error i have only happens when i run it as simple user and doesn't
show up if i login as root.  Here is the message i get:

Mapset <stef> in Location <leics>
GRASS-GRID > Error in startup script: couldn't create error file for
command: no such file or directory
    while executing
"exec xwininfo -id [winfo id .w_g] | grep -i Corners"
    (file "/usr/local/grass42/tcltkgrass/main/gui.tcl" line 1511)
    invoked from within
"source $env(TCLTKGRASSBASE)/main/gui.tcl"
    (file "/usr/local/grass42/bin/tcltkgrass" line 17)

I suppose it is related to writing permissions. Is it safe to allow
writing for all users?  Right now I am the only user of this machine so
I guess I could do that, right?

 The distribution I used had tcltkgrass included. I also tried to untar
the tcltkgrass distributed separately but with no luck.  I have wish8.0.

Thank you for help

Stefano Maffulli
GIS_L.A.B. Land Application Builders - VicePresident
Centre for Interdisciplinary Research and Application of GIS
Via S. Niccolo' 89/a 50121 Firenze Italy
tel. +39 055 2491.533     Fax +39 055 2345.328    ICQ# 39845203
To err is really foul up requires the root password.

More information about the grass-user mailing list