d.mon fails...

Markus Neteler neteler at geog.uni-hannover.de
Thu Sep 9 14:59:13 EDT 1999

> All my fifos are in order (/gis/grass-5.0b3/dev)..... everytime I run the
> d.mon command a lock file is generatet..... I delete the lock file, and
> the next time I run the command a new lock file
> is made.....
> Kjell-Olav Bjerknes..............


it may be required to specify a domain name for the
server. Then a subdirectory is required in locks/ named
like your machine (without domain). Set the permissions
in grass-5.0b3/ with

chmod -R 1777 locks/

The lockfile will be created automatically when starting
a monitor and deleted when stopping the monitor. No need
to edit anything there!

One other problem I know: If you run Linux based on libc5
you cannot use GRASS compiled on libc6 properly. The GRASS
Linux binaries are compiled on libc6 (glibc2). If you still
have a libc5-based system (Redhat 4.x, SuSe 5.x, Caldera 1.3, 
Debian 1.x ...) you should compile the GRASS 5 yourself which
is quite easy now.

Best regards


More information about the grass-user mailing list