[GRASSLIST:1114] Re: (no subject)

mlennert at club.worldonline.be mlennert at club.worldonline.be
Mon Nov 13 07:49:18 EST 2000

> mlennert at club.worldonline.be wrote:
> > 'make distclean' doesn't seem to clean the cache. So I tried 'make
> > veryclean'
> > which does seem to clean the cache, but the problem is still the
> > same...
> Ooops you are right it should be veryclean, sorry. However I think you
> don't have an up to date Makefile.in file. Check if the following is in
> your Makefile.in (the wrapped lines are just a single line):
> pre-install:
>         test -d ${PREFIX} || ${INSTALL_DATA_DIR} ${PREFIX}
>         test -d src/CMD/next_step || mkdir -p src/CMD/next_step
>         test ! -f src/CMD/head/head || mv src/CMD/head/head
> src/CMD/head/head.${ARCH}
> src/CMD/generic/CREATE_GMAKE.sh ${ARCH}
>         ${SHELL} ${IS64BIT} ${ARCH}
>         @ echo "Now proceed with make install"
> If the pre-install target does not appear as above then do a
> cvs update Makefile.in
> make veryclean
> ./configure
> make install
> I'm here for a few more minutes so if you still have problems.

That was it ! 

The Makefile.in did not contain lines 3 and 4 of the pre-install commands. I just did a complete update -dP (update Makefile.in gives me an error message), but the Makefile is still the same. Then I downloaded the Makefile.in directly from the CVS server, and now it works !

I don't know if I'm doing something wrong with the cvs, or wether the problem is somewhere else, but the compilation is running right now...

Thanks a lot Justin and Markus !


More information about the grass-user mailing list