[GRASSLIST:1428] SUM: why I always got "LOCATION_NAME not set" when I start Grass5.0 beta 10?

Bei Zhang Bei_Zhang at ndsu.nodak.edu
Wed Feb 7 12:41:25 EST 2001

Thanks to Carl and Eric for suggestions.

I tried again, but still GRASS gives "LOCATION_NAME not set" message. So I 
guess maybe it's a bug in GRASS5 beta 10. ( later, I downloaded and 
installed GRASS version 4.3, everything works out fine with this version.)



Original question:

> Hi, all,
> I'm new to Grass 5.0 beta 10, here is what I got:
> My operating system is Redhat Linux 7.0, I installed Grass5beta10
> binary at /usr/local/grass, and the tutorial "leics" dataset I
> downloaded from official Grass website was put at
> /home/username/leics/PERMANENT.
> After installation of Grass, I run "grass5" at command line and got
> promption to input GISDBASE, LOCATION_NAME and MAPSET, since it's just
> a try, I pressed "Ctrl+C" to exit the system. Later on, when I typed
> "grass5 /home/username/leics/PERMANENT", Grass initiated and
> automatically loaded the tcl/tk GUI, but when I tried to do something
> like "g.list", I got a "LOCATION_NAME not set" error message
> everytime. But when I typed "set" at command line in Grass, I can see
> that the LOCATION_NAME has been assigned "leics", and MAPSET assigned
> "PERMANENT". So I don't know why I got "LOCATION_NAME not set".
> Could anybody give me a answer? (Grass 5 manual "startup" section
> doesn't seem to help much)



--On Tuesday, February 06, 2001 6:36 PM -0500 cbsled at ncia.net wrote:

> I'm new to GRASS too, so I might be way off...
> I believe the directory structure must be:
> That is, $LOCATION_NAME must be a subdirectory of $GISDBASE.
> If you need to locate it elsewhere for some reason, symlink to it.
> Check the grassrc file in your home directory.
> My installation (compiled on Redhat 6.2) crashes if I try to change the
> location or mapset  in the tcl/tk  pick box that opens on start up. I set
> them in my grassrc before starting GRASS.
> --
> -----------------------------------------------------------
> Carl Brown cbsled at ncia.net
> -----------------------------------------------------------
> Microsoft: The company that made eMail dangerous.


> Try starting grass5 without any command line parameter, set the
> gisdbase, location and mapset values (/home/<user>, leics, PERMANENT)
> and then key <ESC> <ENTER>.  Maybe just the funky mapset initialization
> is not happening the other way (bug?) -- there are some shell spawning
> tricks GRASS plays...
> --
> Eric G. Miller <egm2 at jps.net>

More information about the grass-user mailing list