[GRASSLIST:5171] Re: jpeglib.h

Glynn Clements glynn.clements at virgin.net
Fri Dec 6 16:19:42 EST 2002

Isabel Sargent wrote:

   I am trying to install GRASS on a Dec Alpha Tru 64 machine. I have not
   allowed root permissions and so am installing in my own filespace.
   When I originally configured using
   ./configure --prefix=/usr/d0/izzy/ --with-bindir=/usr/d0/izzy/
   I got messages saying that the zlib and jpeglib includes could not be
   found. I
   was able to install zlib and did not have the error message for this
   anymore. I
   thought I had installed jpeg (v6b from ftp.uu.net/graphic/jpeg) but
   was not automatically put into my include directory when I used make
   install. I
   have tried manually copying jpeglib.h from the untarred directory into
   includes directory but when I configure using
   ./configure --prefix=/usr/d0/izzy/ --with-bindir=/usr/d0/izzy/
   I still get the messages
   checking for location of jpeg includes... /usr/d0/izzy/include
   checking for jpeglib.h ...no
   configure:*** Unable to locate jpeg includes
   What am I doing wrong?

jpeglib.h also needs jconfig.h and jmorecfg.h; unless those files are
also present, the test will fail.

Also, JPEG isn't essential. No program requires it directly; you only
need it if you are using a version of the TIFF, GD or GDAL libraries
which themselver require JPEG. If you have problems, you can disable
the JPEG checks using configure's --without-jpeg switch (similar
switches exist for the other optional libraries).

Glynn Clements <glynn.clements at virgin.net>

More information about the grass-user mailing list