[GRASSLIST:3150] Cannot get the makefile to work

Robert Holmes robert at holmesacosta.com
Tue Apr 13 19:54:24 EDT 2004

Hi all,

I'm trying and failing to install GRASS 5.0.3 from source code. I suspect
I'm doing something truly dumb but I'm not sure what and I'd appreciate your

As suggested in the installation instructions, I've created a directory (as
root) /opt/src/grass5sources and unpacked grass-5.0.3_src.tar.gz. Changing
to the directory grass5.0.3, I then run ./configure, which appears to run OK
(the only error is it cannot locate TIFF includes. This is an optional
module so I figured it should be OK).

Now comes the problem - when I run make I get the response:
	bash: make#: command not found
which is understandable because there isn't a Makefile in my grass5.0.3
directory. There is a Makefile.in though, and when I run that (make -f
Makefile.in), it only runs briefly before failing thus:
@SRCDIR@/src/CMD/generic/is64bit.sh: No such file or directory

What am I doing wrong? Any guidance gratefully received,

Robert Holmes

More information about the grass-user mailing list