[GRASSLIST:3191] Re: gmake53 problem

Massimiliano Cannata massimiliano.cannata at supsi.ch
Fri Apr 16 06:14:20 EDT 2004

I have tryed to recompile everything, so here is my runs:

    * make distclean
    * find / -name gmake53
    * i remove all the gmake53, gmakelinks53 and grass53
    * configure with:
      CFLAGS="-O3 -mcpu=pentium -Wall" ./configure  --prefix=/home/grass
      --with-postgres-includes=/usr/include/pgsql/server/ --with-motif
      --with-motif-libs=/usr/X11R6/LessTif/Motif1.2/lib/ --with-blas
      --with-lapack --with-glw --with-dbm
      --with-dbm-includes=/usr/include/gdbm --with-freetype
      --without-readline --with-fftw --with-proj
      --with-proj-libs=/usr/local/lib --with-cxx

    * make
    * make install

Now I get a my grass running correctly with all the commands, i also 
have a new /home/grass/bin directory with gmake53, gmakelinks53 and 
grass53 files just created (those shold be the rigth ones).
Unfortunately when i try to compile my new code it continues to give the 
same error:

/usr/bin/ld: cannot open output file /etc/bin/cmd/r.interception: No 
such file or directory
collect2: ld returned 1 exit status
make: *** [/etc/bin/cmd/r.interception] Error 1

I see that my gmake53 contain the line INST_DIR=/home/grass/grass53

It compile correctly the code but the installation that fails....
I suppose that instead of  /etc/bin/cmd/r.interception it should be 

In fact I can find it in 
the problem is just in copying it in the /home/grass/grass53/bin directory?

Paul Kelly wrote:

>On Thu, 15 Apr 2004, Massimiliano Cannata wrote:
>>sorry, i run
>>ln -s /home/bin/gmake53 /usr/local/bin/gmake53
>>but also using  /home/bin/gmake53 the output is always the same......
>Well yes because you are still running the wrong gmake53 (assuming the
>configure line you gave in your last message is correct). You said
>--bindir=/home so the correct version is /home/gmake53.
>If you did --bindir=/home/bin then it would be /home/bin/gmake53
>What does
>find / -name gmake53
>show... are there several copies of gmake53 on your system?
>The way I see it the gmake53 in /usr/local/bin (and perhaps /home/bin also)
>seems to be old and out of date and doesn't have the line
>that should be there since 25th March when I made some improvements to the
>gmake script.
>Let me know how you get on.

note: change my e-mail reference to massimiliano.cannata at supsi.ch
      because the old one will be deleted soon.
Ing.  Massimiliano Cannata
Istituto di Scienze della Terra - SUPSI
C.P. 72 - CH-6952 Canobbio (Ticino, Switzerland)
Tel +41 91 /935 12 25 - Fax +41 91 /935 12 09
eMail: massimiliano.cannata at supsi.ch
Internet: http://www.ist.supsi.ch

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20040416/e8a08087/attachment.html

More information about the grass-user mailing list