[GRASSLIST:7219] Re: Compile Errors continue in 6.0.0

Thomas Colson tom_colson at ncsu.edu
Fri Jun 17 23:35:44 EDT 2005

tried that. Tried ./configure --without-fftw AND --without-gdal (or
with-gdal=no...interesting enough, either of the disable gdal syntaxes
still bombs with "Can't find GDAL")

Same errors. Could this be due to the version of GCC (4.0)? Or the version
of Fedora? Unfortunately, getting FC3 working on my hardware is harder
than getting grass to work (Dual Xeon 3.6, 256 MB vid card, hardware
RAID...) and FC4 works perfectly out of the box. The precompiled binaries
at mappinghacks.com of course are not applicable to my distro of linux
(worked great on a FC3 laptop install with Grass 6.1).

I'm getting pretty desperate here....I MUST get this working sometime this
weekend. Basically, the only thing I need working is v.in.ascii and
r.surf.rst (and NVIZ...hence...a GUI). The goal here is speedy
interpolation of LIDAR elevation points into DEMs using spline, ideally
with libraries optimized for large file support and the 64 bit

Or....is 6.0.0 compatible with fftw 3.0 yet?

> I would guess everything else fails becasue gmath fails.
> If you don't need the i.fft modules for satellite imagery processing,
> just configure grass without it:
> ./configure --without-fftw
> only a couple of modules use it.
> (good to get it fixed though if it is a bug)
> Hamish

Thomas Colson
Center For Earth Observation
North Carolina State University
Raleigh, NC
(919)515 3434
(919)673 8023
tom_colson at ncsu.edu

More information about the grass-user mailing list