[GRASS-user] v.in.gpsbabel, Garmin USB and Macintosh

Dave Kent dkent at sasktel.net
Fri Sep 22 23:19:09 EDT 2006

Thanks for your and Paolo's help.

GPSBabel+  works real fine on it's own.   I am using the sourceforge   
1.3.0 binaries for PPC on a G5 PPC machine.  Grass is your 6.3CVS  
binaries. (Thanks)

I can use GPSBabel+  directly to download from the gps device and  
save in GPX format.  I can then import the GPX format with  
v.in.gpsbabel.  The data goes in as points  in the Location's  
coordinate system.  I had thought (and hoped) from the documentation  
that track data would import as an arc.  I need to work on this.

The attribute columns  are in the format (in grass) of easting,  
northing, elevation, day, time, and a blank column

Nonetheless,  I can get the job done.

I stumbled across utility USB prober  on the system.  It sees the  
Garmin device with partial output as follows:

Full Speed device @ 5  
(0x4B120000): .............................................   Vendor- 
specific device from Garmin International
     Device Descriptor
         Descriptor Version Number:   0x0110
         Device Class:   255   (Vendor-specific)
         Device Subclass:   255   (Vendor-specific)
         Device Protocol:   255
         Device MaxPacketSize:   64
         Device VendorID/ProductID:   0x091E/0x0003   (Garmin  
         Device Version Number:   0x0001
         Number of Configurations:   1
         Manufacturer String:   0 (none)
         Product String:   0 (none)
         Serial Number String:   0 (none)

I could not get a response with ls -l cu.*   I assumed this was from  
the console.

I listed /dev/ as per Paolo's note.  There are many devices but none   
with "usb" in the names.

I am pretty much at a loss in discovering the device name, but it is  
not too much of an extra step to go through an intermediate file.

Thanks again.


On Sep 22, 2006, at 9:31 AM, William Kyngesburye wrote:

> I've tried some gpsbabel stuff on Mac OS X.  I have a Magellan MAP  
> 330, it's serial, so I need to run in thru a USB-Serial converter.   
> So far not much luck with gpsbabel, tho I can get it to work with  
> other Mac GPS apps.  I don't have a USB GPS device to test.
> I don't see any *usb* devices, like Paolo mentioned, even cu.usb*.   
> I guess usb keyboards and mice get their own special naming, and  
> the usb-serial converter is cu.USA19QW3d1P1.1.  You could try ls -l  
> cu.* instead to see what's there, maybe the Garmin is named without  
> 'usb'.  Try it before and after the Garmin is plugged in.
> What gpsbabel are you using?  The GPSBabel+ you can find for Mac OS  
> X, or your own build?  Which version?  PPC or Intel Mac?  That  
> GPSBabel+ is PPC-only, and may have problems running thru Rosetta  
> on Intel Macs (it shouldn't).
> On Sep 22, 2006, at 12:45 AM, Dave Kent wrote:
>> Hi all.
>> I am trying to download gps data using v.in.gpsbabel.  I have a  
>> Garmin C60 gps and am using Grass 6.3CVS on  mac os 10.4.  I am  
>> using the USB connection.
>> The gpsbabel application on its own works.
>> When I try v.in.gpsbabel I get.
>> Downloading Tracks from GPS
>> [ERROR] XSERIAL: Cannot open serial port '/dev/cu.usbserial0': ?ÿç  
>> No such file or directory
>> [ERROR] Cannot open serial port '/dev/cu.usbserial0'
>> GARMIN:Can't init /dev/cu.usbserial0
>> v.in.gpsbabel: Error retrieving data
>> I have tried many device names including those in the help  
>> pages.  /dev/cu.usbserial0  in the above example was from   http:// 
>> wiki.openstreetmap.org/index.php/MakingGpxTracks
>> Has anyone had success with this combination?  What device name  
>> works?
>> Thanks for your help.
>> Dave
>> _______________________________________________
>> grassuser mailing list
>> grassuser at grass.itc.it
>> http://grass.itc.it/mailman/listinfo/grassuser
> -----
> William Kyngesburye <kyngchaos at kyngchaos.com>
> http://www.kyngchaos.com/
> "Mon Dieu! but they are all alike.  Cheating, murdering, lying,  
> fighting, and all for things that the beasts of the jungle would  
> not deign to possess - money to purchase the effeminate pleasures  
> of weaklings.  And yet withal bound down by silly customs that make  
> them slaves to their unhappy lot while firm in the belief that they  
> be the lords of creation enjoying the only real pleasures of  
> existence....
> - the wisdom of Tarzan

More information about the grass-user mailing list