[GRASS-user] RE: Problem querying layers other than '1' in gi s.m

Patton, Eric epatton at nrcan.gc.ca
Mon Sep 25 12:13:56 EDT 2006

I tried renaming within sqlitebrowser to no avail. I posted the error within
my message a few posts ago. I'm unfamiliar with a lot of the SQL syntax, but
I tried:

ALTER TABLE  Video_Benthos
RENAME Rumbolt_Video_Benthos_Uncorrected_UTC_NR.ID ID ;

But I'm most likely getting the syntax incorrect. Any ideas?

~ Eric.

-----Original Message-----
From: Moritz Lennert
To: Patton, Eric
Cc: ''Dylan Beaudette ' '; ''grassuser at grass.itc.it' '
Sent: 9/25/2006 11:23 AM
Subject: Re: [GRASS-user] RE: Problem querying layers other than '1' in gi

Patton, Eric wrote:
>>> Could the error I'm getting be caused by the length of the new field
>>> names? 
>> I think the problem is rather the period in the name.
>>From the Postgresql documentation:
>> "SQL identifiers and key words must begin with a letter (a-z, but
>> letters with diacritical marks and non-Latin letters) or an
>> (_). Subsequent characters in an identifier or key word can be
>> underscores, digits (0-9), or dollar signs ($)."
>> Moritz
> Strange then that Sqlite writes these column names itself?! 

No time to check this now, but probably sqlite allows such column names,

but GRASS tries to enforce SQL standards which probably don't allow

> I exported the
> tables as csv, opened it in OOffice, and just renamed the columns. It
> to be behaving now.

Couldn't you modify them in sqlite directly ?


More information about the grass-user mailing list