[GRASS-user] Re: Cygwin winGRASS 6.2 Errors!

yuri bay ksh_wong at msn.com
Thu Feb 15 04:37:23 EST 2007


>Hamish wrote:
> > > > $ grass62
> > > > # GUI Startup
> > > > # select spearfish
> > > > # gis.m starts up but then crashes:
> > > > ...
> > > > GRASS 6.2.1 (spearfish60):~ > child process exited abnormally
>got it!
>$ cygcheck g.region
>shows that the fftw3 DLL couldn't be found.
>$ cygcheck i.pca
>shows that the jasper (JPEG 2000) DLL couldn't be found.

I have installed the fftw and jasper and have cygcheck the above and I have 
a different errors:

Could not find cygcripto-0.9.8.dll and cygssl-0.9.8.dll, and I cannot seem 
to find Crypto or SSl packages in cygwin install??

I have also tried after installing the fftw and jasper, to see if using xwin 
on GRASS start up will work.  But I have the same child process error when 
trying to start a mapset.  However I have the following TCLTK error when I 
tried to use gis.m in cygwin command shell instead of xwin.  Is this because 
I am not using xwin?

-Application initialization failed: no display name and no $Display 
environment variable
-Error in start up script: dynamic loading is not currently available in 
this system
-while executing
-"load /usr/local/lib/tk8.4/../libtk8.4.a Tk"
-("package ifneeded" script)
-invoked from within
-"package require TK 8.0"
-("package ifneeded" script)
-invoke from within
-"package require -exact BWidget 1.2.1"
-(file "/usr/local/grass-6.2.1/etc/gm/gm.tcl" line 24)

Many thanks for your help and advice.

Best Regards

Get Hotmail, News, Sport and Entertainment from MSN on your mobile.  

More information about the grass-user mailing list