[GRASS-user] Re: Cygwin winGRASS 6.2 Errors!

Hamish hamish_nospam at yahoo.com
Thu Feb 15 05:48:15 EST 2007

> Hamish wrote:
> GRASS 6.2.1 (spearfish60):~ > child process exited abnormally
> >
> >got it!
> >
> >$ cygcheck g.region
> >shows that the fftw3 DLL couldn't be found.
> >
> >$ cygcheck i.pca
> >shows that the jasper (JPEG 2000) DLL couldn't be found.

yuri bay wrote:
> I have installed the fftw and jasper and have cygcheck the above and I
> have a different errors:
> Could not find cygcripto-0.9.8.dll and cygssl-0.9.8.dll, and I cannot
> seem to find Crypto or SSl packages in cygwin install??

putting those file names into the Cygwin package search engine:


Which tells us you need to install the openssl package.
 (needed by the Postgres DB?)

I may have installed another package which sucked that in automatically.

> I have also tried after installing the fftw and jasper, to see if
> using xwin on GRASS start up will work.  But I have the same child
> process error when trying to start a mapset.  However I have the
> following TCLTK error when I tried to use gis.m in cygwin command
> shell instead of xwin. Is this because I am not using xwin?

You need to be in an xterm to open an X monitor. The regular command
shell is just a Windows cmd window AFAICT, and that knows nothing of


More information about the grass-user mailing list