[GRASS-user] Trying to rename a column

Alex Mandel tech_dev at wildintellect.com
Thu Aug 14 01:00:33 EDT 2008

Quick trick to try then is to open the dbf with OpenOffice you'll see 
the column specs is the 1st line with the column name. Just change the 5 
to an 8. Or do the copy method you mentioned.

I've never seen another way to easily do it. You should think about 
changing to sqlite though, I was under this impression that it was the 
default for 6.3


Thomas.Adams at noaa.gov wrote:
> Alex,
> dbf; just the default for a generic vector file. I should have added more detail, such as that I am using GRASS 6.3 on Linux.
> Thanks,
> Tom
> ----- Original Message -----
> From: Alex Mandel <tech_dev at wildintellect.com>
> Date: Wednesday, August 13, 2008 10:55 pm
> Subject: Re: [GRASS-user] Trying to rename a column
>> Thomas Adams wrote:
>>> List:
>>> Ultimately what I am trying to do is to make a varchar(5) field 
>> be a 
>>> varchar(8) field — but I don't see how to do this directly. So, I 
>>> thought if I created a new varchar(8) column, copied the values 
>> of the 
>>> varchar(5) column into it (This all worked fine); then, renamed 
>> the 
>>> varchar(5) column to 'foo' (which also worked), then I could 
>> rename the 
>>> varchar(8) column to what the column name was for the original 
>>> varchar(5) column — this does NOT work. Also, I would like to 
>> delete the 
>>> 'foo' column, but I don't see how to do this.
>>> Any suggestions?
>>> Thanks,
>>> Tom
>> What's the data backend you're using? dbf, sqlite, postgis?
>> Alex

More information about the grass-user mailing list