[GRASS-user] Can't find signature file for i.cluster or i.class

Hamish hamish_b at yahoo.com
Wed Jun 11 07:26:40 EDT 2008

William Hudspeth wrote:
> I am trying to do a multispectral reclassification with
> ASTER data.
> While the i.cluster and i.class modules seem to run to
> completion, I cannot find the signature files to use with
> i.maxlik. Does anyone know where the are written to?

Look in $MAPSET/group/$GROUP/subgroup/$SUBGROUP/sig/
The i.class help page is now updated to say that.

It is created by I_fopen_signature_file_new() found in lib/imagery/sigfile.c if you want to follow the trail.

> Also, when I run i.cluster, I have tried changing many of
> the parameters, but find it difficult to get a reasonable
> number of classes when the convergence is set to the default
> 0.98. Are there any guidelines for working with i.cluster?
> It is probably worth noting that I am trying to run
> i.cluster and i.class on the output from i.pca...

It's outside of my field, so no idea, but if you find some answers it would be nice to write up a little help section on the wiki:

Currently that just says "see the GRASS book".



More information about the grass-user mailing list