[GRASS-user] error: Incompatible library version for module. You need to rebuild GRASS or untangle multiple installations.

Nikos Alexandris nikos.alexandris at felis.uni-freiburg.de
Tue Jul 28 22:46:57 EDT 2009

stephen sefick wrote:

> What computer architecture, operating system, what R version etc.?

Right, I assume that people know that I am using Ubuntu Jaunty 64-bit, R
2.9.1, latest rpy2, grass-6.4.0svn from source.

> What is the error message? 

The message is the title of this thread.

> I am usingce 6.4RC5 GRASS and R 2.9.1 on mac
> OS X 10.5.7, and it is working fine. I remember there being a problem
> with something, but I don't remember exactly what.  If you were to
> provide the error message then maybe it would jog my memory.

Sorry, that's all the prog prints.

> Also, it may be a good idea to search the R-sig-geo list archive, as your
> problem may have already been solved (assuming it is the same one that
> I had).

Before doing countless compilations/installations I filtered the web for
an hour! I've found some similar messages in grass-dev's mailing-list
but nothing specific.

I thought that /etc/ld.so.conf is my problem... and I commented out all
grass-versions but grass-6.4.0svn. I even removed all other
grass-versions, (re-)installed X-times spgrass6 but no luck.

It's the first time I see this message. I also tried to do some
debugging but R requires, I guess, special treatment (meaning other than
gdb, etc.) !?


More information about the grass-user mailing list