[GRASS-user] v.lidar.edgedetection very slow

John Tate john.tate at ntlworld.com
Fri Jun 19 07:43:37 EDT 2009

>> As it is writing the file (was at 6Mb after 3hrs), the mem usage is
>> on 114Mb with 1.4Gb free at the moment. It is not using the PageFile.
> .... is that at 100%/4(25%) or 1% CPU?

The RAM was increasing gradually also. It's at 1% CPU.

I tried again with a 182kb tile and the process took 10mins or so. It was 
using the RAM, increasing up to around 50Mb and 25% CPU usage then drops to 
minimal RAM and 1%CPU. It did this twice during the process. Presumeably for 
the two files, cleaned and oultiers. At the point it starts writing the 
file, it is at the slow speeds mentioned.

>> Does the edge file equate to a similar size, e.g. will it
>> take about 47000 seconds to write the file? Is there a rough percentage
>> of the size of edge file compared to original txt file? I notice it is
>> also writing to the sqlite.db at the same time.
> no idea about file sizes. In 6.5svn and 7svn I've just added some
> verbose messages (add --verbose) and some percent done indicators
> so it will seem like less of a black box now.

This 182kb file equated to 408kb edge file.

> also you can turn on some debug messages to follow the action:
> g.gisenv set="DEBUG=1"

Cheers, will try this.

>> Have I done something wrong?
> one thing to check: did you run 'g.region vect=lidar_points res=2 -ap'
> before starting? v.lidar.edgedetection seems to use the current
> computational region settings for something.

yes, though at 'res=1' for this dataset and didn't use '-ap'

>> The book and manual says it needs topology for lidar tools to work.
>> Does it need the database?
> I don't think it needs either. Where abouts does it say that?

p252 of 3rd edition '#build topology so that we can use all vector tools'. 
However, the method on p256-257 does not mention db or topology. Also, when 
I have tried to run v.oultier without db/topology it says it cannot as there 
is no database.  I will look at this again later. Maybe I am not selecting 
3D when I have tried without db etc.


More information about the grass-user mailing list