[GRASS-user] Re: Importing of raster data doesn't seem to work through GUI

Micha Silver micha at arava.co.il
Mon Dec 6 01:46:39 EST 2010

On 06/12/2010 01:49, Chethan S. wrote:
> Greetings!
> I use Ubuntu 10.04 64-bit. This bulk import feature never worked for me. I
> am attaching a screenshot now. In the screenshot, the directory has no
> metadata and other text files, but I have tried importing with those files
> inside the directory as well.

Why not do your bulk import from the GRASS command line with a 
Something like:
cd <your landsat directory>
for f in *.tif; do r.in.gdal $f out=`basename $f .tif`; done

> http://osgeo-org.1803224.n2.nabble.com/file/n5806289/Selection_021.png
> Regards,
> Chethan S.
> Martin Landa wrote:
>> Hi,
>> 2010/12/5 Chethan S<chethanuniversal at gmail.com>:
>>> I have been trying to import raster data in bulk through the wxPython GUI
>>> in
>>> Grass Layer Manager using File>  Import Raster Data>  Import Raster Data
>>> in
>>> GRASS 6.4.1 SVN. I have tried setting source type as "File" and
>>> "Directory".
>>> As I use landsat data the format is GeoTIFF. As I navigate and select
>>> particular folder/data nothing appears in "List of GDAL layers". I have
>>> tried in two ways - with metadata and other text files residing in the
>>> same
>>> folder as the satellite data and keeping text files in another folder.
>>> Nothing changed. Therefore, I have to select "Command Dialog" and import
>>> the
>>> data band by band. Am I missing something in the process?
>> OS? Tested with fresh 6.4.1 from SVN. Seems to work. URL to the sample
>> data?
>> Martin
>> -- 
>> Martin Landa<landa.martin gmail.com>  * http://geo.fsv.cvut.cz/~landa
>> _______________________________________________
>> grass-user mailing list
>> grass-user at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/grass-user

Micha Silver
Arava Development Co.  +972-52-3665918

More information about the grass-user mailing list