[GRASS-user] No elevation in dxf polylines

Adam Dershowitz, Ph.D., P.E. adershowitz at exponent.com
Tue Dec 14 09:10:25 EST 2010

I hunted around some more.  
It looks like that was fixed by hcho in changeset 36804, 20 months ago.  
So, either it wasn't actually fixed correctly, or that change was not incorporated into the binary that I have?  Is there a way to determine that easily?
If it was not included, I would greatly appreciate it if, it could be added in.  I am hoping not to have to download and build everything, just to get this one fix.



On Dec 14, 2010, at 5:48 AM, Adam Dershowitz, Ph.D., P.E. wrote:

> A while back I received a dxf file that contained contour elevation lines.  The problem is that when I imported it, the polylines all showed up at elevation 0, instead of at their correct elevation.
> At the time, I had several discussions about this, but never figured out a solution.  Then, a year and a half ago, I saw a similar problem crop up on this list, along with a final outcome that it had been fixed, but no other details about that.
> I just received a new elevation contour dxf file, from a different source, and sure enough, I am having the same problem with it.  It seems to import fine, but the polylines all show as elevation 0.  
> I tried to import both with v.in.dxf and with v.in.ogr.  In the second case, I also tried -z.  
> I am on a Mac using Kyngesburye's GRASS-6.4.0-3-Snow.
> Any suggestions would be greatly appreciated.  
> Thanks,
> --Adam
> _______________________________________________
> grass-user mailing list
> grass-user at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/grass-user

More information about the grass-user mailing list