[GRASS-user] Large File Support (LFS)

Hamish hamish_b at yahoo.com
Sat Mar 20 21:21:06 EDT 2010

John wrote:
> I complied and installed grass6.4 with large file support
> (ubuntu9.10 on a 32bit machine). All went well with no errors.

> I ran my lidar script to test it, and straight away failed on
> the 3.4Gb ascii file import with r.in.xyz to get stats. I
> tried a 500Mb file and it was fine.

how did it fail? what was the exact error message and command
line used? what does "g.region -p" say?

> I found this: http://grass.osgeo.org/wiki/Large_File_support
> and guess that is I why I never had a problem on my 64bit
> machine.

No, LFS should be mostly irrelevant for r.in.xyz. The version in
6.4 without LFS should handle input files of hundreds of
gigabytes just fine. The only thing which might get messed up
is the % done, but that's just a harmless informational message.

worst come to worst, pipe from stdin instead of reading from a
file, but I'm skeptical that LFS is the cause.

I suspect you are running out of memory, for very large regions
with extended stats (median,percentile,skewness,trimmean) you
should make use of percent=25 or so as needed.

Or if there's a bug, I'd like to know about it.



More information about the grass-user mailing list