[GRASS-user] Large File Support (LFS)

John Tate john.tate at ntlworld.com
Sat Mar 20 14:40:16 EDT 2010

On Saturday 20 March 2010 18:31:58 Glynn Clements wrote:
> John Tate wrote:
> > I complied and installed grass6.4 with large file support (ubuntu9.10 on
> > a 32bit machine). All went well with no errors. I ran my lidar script to
> > test it, and straight away failed on the 3.4Gb ascii file import with
> > r.in.xyz to get stats. I tried a 500Mb file and it was fine.
> >
> > I found this: http://grass.osgeo.org/wiki/Large_File_support
> >
> > and guess that is I why I never had a problem on my 64bit machine.
> >
> > What is the current state over this issue? Is there an easy fix
> > (considering I am still relatively new to linux), or do I have to wait
> > for the completion of the wish list on the wiki? What are the likely
> > timescales? Is this an issue with grass7 also?
> In 7.0, --enable-largefile causes everything to be compiled with
> -D_FILE_OFFSET_BITS=64. Most uses of fseek/ftell have been replaced
> with G_fseek() and G_ftell(), which accept and return an off_t, and
> which use fseeko/ftello where available.

Ok. I didn't get that on the webpage either. Goes over my head :)
A work around I guess?
So in 7.0 I can use files over 2Gb on a 32bit machine?

> I have no idea whether widespread LFS will make it into 6.x.
Right, time to rewrite the bash scripts...



More information about the grass-user mailing list