[GRASS-user] Unable to load gdal library error

Daniel Victoria daniel.victoria at gmail.com
Fri Sep 24 08:29:48 EDT 2010

Tried recompiling grass but that did not change anything. So I ran ldd
`which r.what` and it did not show any links to a gdal library... This
is what I got

GRASS 6.5.svn (br_wgs84):~ > ldd `which r.what`
	linux-gate.so.1 =>  (0x00f71000)
	libgrass_gis.so => /usr/local/grass-6.5.svn/lib/libgrass_gis.so (0x00a31000)
	libgrass_datetime.so =>
/usr/local/grass-6.5.svn/lib/libgrass_datetime.so (0x00c02000)
	libz.so.1 => /lib/libz.so.1 (0x002ca000)
	libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0x00681000)
	libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x00d3d000)
	libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x00ace000)
	/lib/ld-linux.so.2 (0x005a5000)
GRASS 6.5.svn (br_wgs84):~ >

Does this means that I messed up during compilation?



On Fri, Sep 24, 2010 at 2:00 AM, Hamish <hamish_b at yahoo.com> wrote:
> Daniel wrote:
>> >> r.external [...]
>> >> ERROR: Unable to load GDAL library.
> ..
>> It's strange cause I can use gdalinfo and gdal_translate on the SRTM
>> tif tiles and last night I patched them using gdal_merge.py. Also,
>> r.in.gdal works fine. And I can run r.info on the tiles imported using
>> r.external. But I can't display them or query the values (r.what also
>> gives ERROR: Unable to load GDAL library).
> try
> ldd `which r.what`
> and examine if the GDAL library versions are consistent with what you
> think it should be using (`gdalinfo --version` and ldd `which gdalinfo`)
> if gdal was upgraded after grass was built, grass may need to be rebuilt
> against the new version of gdal..
>> However, since I'll be running r.terraflow on this huge SRTM image,
> MMetz will suggest you try the new r.watershed too :-)
>> would it be faster to import the image and then run r.terraflow?
> probably.
> Hamish

More information about the grass-user mailing list