[GRASS-user] RE: query tool in wxGUI doesn't work on multiple table connections

Shane Litherland litherland-farm at bigpond.com
Sat Dec 24 00:54:03 EST 2011

I found another case where the tool seems to not function fully:

A different vector to my earlier post, has for a given centroid:
layer 1: cats 4,5 and 107
layer 2: cat 40

I checked the connection to this info is fine within the wx digitiser
using the attributes tool there.

the query tool in general view though, only reports the data for this
point to match layer 1, cat 107. none of the other cats have a tab
showing their data.

elsewhere in that same vector, i found a centroid where I got same error
messages as earlier reported, the layer/cat details for that were:
layer 1, cats 1 and 2
layer 2, cat 39

a third centroid was OK, with layer 1, cats 76 - 81, but the query tool
only showed data for cat 81.

a fourth centroid, only layer 1, cat 33, was reported OK by the query

a fifth centroid, layer 1, cat 2 and layer 2 cat 39, gave an error with
the query tool.

I noted that the cases that the query tool gave an error, at least one
of the entries for layer one had a 'null' value for the 'notes' column
in my table.

however, with the fifth centroid example above, which had a blank notes
field, I entered a note, but that did not stop the query tool giving an
error message.

I went back to the first centroid which for some reason did not report
an error despite having multiple connections on layer one and one
connection on layer two, compared to example two which had a very
similar setup but gave the errors:
I could not see any difference in the details for the relevant entries
in the table/column that gave an error in the latter.
The only thing I could figure out is that the centroid that the query
tool partly worked for had layer 1, cat 107 data returned which just
happened to be a different date (in relevant table column) to the data
on layer 2, whereas the centroid that gave an error had the same date
for the data on both layers. This does not explain anything to me though
because I have not got any connections/joins etc between these tables
based on a date field (unless table conditions that I set up in
PostgreSQL have any bearing on GRASS??)

Does this make the problem any clearer to anybody else? I don't
understand enough about the query tool to eliminate possible sources of
the error despite this testing.


More information about the grass-user mailing list