[GRASS-user] i.cluster not working in GRASS 7

Nick Jachowski njachowski at gmail.com
Fri Feb 18 03:38:53 EST 2011

Hi Ned and Daniel,

I have run into this problem in the past, and I believe it may have to do
with your convergence, min_size, and classes settings.  Try decreasing some
of those and see if you don't get better results.  You can also try
increasing your separation from 0.0 (the default) to 1.0 or 1.5.


On Fri, Feb 18, 2011 at 4:24 PM, daniel mcinerney <
daniel.o.mcinerney at gmail.com> wrote:

> Hi Ned,
> I have been using i.cluster in GRASS 7 on a 64-bit fedora server,
> without any trouble.  However, I managed to replicate your problem
> and create a single class output by setting the parameter
> 'sample=5,5' as you had done in your example. If I run i.cluster without
> that parameter, the signature file and classification output both
> have the number of predefined classes.
> Can you see if this helps with your data?
> Regards,
> Daniel.
> On Thu, Feb 17, 2011 at 7:49 PM, Ned Horning <horning at amnh.org> wrote:
>> Hi - I would like to do an unsupervised classification using i.cluster
>> from GRASS 7 on my Ubuntu 64-bit machine. When I run i.cluster then i.maxlik
>> on a Landsat image I only get one output class, the entire image. Only one
>> class appears in the signature file so the problem is with the i.cluster
>> step. I tried running i.cluster on different images and always get just one
>> class.
>> Here is the command line I'm using:
>> i.cluster group=TM_r15c33 at PERMANENT subgroup=AllBands
>> signaturefile=IsoDataSigs2 classes=20 sample=5,5 convergence=99.9
>> min_size=10000
>> Is anyone able to get i.cluster to work properly? It would be helpful to
>> know if it's a user problem or a bug.
>> Thanks in advance to anyone who can help.
>> All the best,
>> Ned
>> _______________________________________________
>> grass-user mailing list
>> grass-user at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/grass-user
> _______________________________________________
> grass-user mailing list
> grass-user at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/grass-user
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20110218/4caa3cd9/attachment.html

More information about the grass-user mailing list