[GRASS-user] i.cluster not working in GRASS 7

Ned Horning horning at amnh.org
Fri Feb 18 15:05:11 EST 2011

Nick and Daniel,

Thanks for the suggestions. I did manage to get it to run after playing 
with some of the variables. If I used the default values for "sample" 
and "min_size" it worked. Unfortunately the default values are less than 
ideal. I think the main problem is with the "sample" parameter. When I 
enter "sample=5,5" I assume that every fifth pixel from every fifth line 
is being sampled for use in calculating the cluster statistics. This is 
apparently too many samples for i.cluster to handle. If I use 
"sample=100,100" the program works as expected (more or less). I have a 
feeling that the sample array is not able to handle a large number of 

Thanks again,


On 02/18/2011 09:22 AM, Nick Jachowski wrote:
> Also, make sure you mask any Nulls since that often seems to be the 
> problem when i.cluster doesn't work as expected, especially if you are 
> using landsat 7 slc-off imagery - although I've also experienced it 
> with Landsat 4 and 5 imagery.
> [Sent from a mobile device]
> On Feb 18, 2011, at 4:38 PM, Nick Jachowski <njachowski at gmail.com 
> <mailto:njachowski at gmail.com>> wrote:
>> Hi Ned and Daniel,
>> I have run into this problem in the past, and I believe it may have 
>> to do with your convergence, min_size, and classes settings.  Try 
>> decreasing some of those and see if you don't get better results. 
>>  You can also try increasing your separation from 0.0 (the default) 
>> to 1.0 or 1.5.
>> Nick
>> On Fri, Feb 18, 2011 at 4:24 PM, daniel mcinerney 
>> <daniel.o.mcinerney at gmail.com <mailto:daniel.o.mcinerney at gmail.com>> 
>> wrote:
>>     Hi Ned,
>>     I have been using i.cluster in GRASS 7 on a 64-bit fedora server,
>>     without any trouble.  However, I managed to replicate your problem
>>     and create a single class output by setting the parameter
>>     'sample=5,5' as you had done in your example. If I run i.cluster
>>     without
>>     that parameter, the signature file and classification output both
>>     have the number of predefined classes.
>>     Can you see if this helps with your data?
>>     Regards,
>>     Daniel.
>>     On Thu, Feb 17, 2011 at 7:49 PM, Ned Horning <horning at amnh.org
>>     <mailto:horning at amnh.org>> wrote:
>>         Hi - I would like to do an unsupervised classification using
>>         i.cluster from GRASS 7 on my Ubuntu 64-bit machine. When I
>>         run i.cluster then i.maxlik on a Landsat image I only get one
>>         output class, the entire image. Only one class appears in the
>>         signature file so the problem is with the i.cluster step. I
>>         tried running i.cluster on different images and always get
>>         just one class.
>>         Here is the command line I'm using:
>>         i.cluster group=TM_r15c33 at PERMANENT subgroup=AllBands
>>         signaturefile=IsoDataSigs2 classes=20 sample=5,5
>>         convergence=99.9 min_size=10000
>>         Is anyone able to get i.cluster to work properly? It would be
>>         helpful to know if it's a user problem or a bug.
>>         Thanks in advance to anyone who can help.
>>         All the best,
>>         Ned
>>         _______________________________________________
>>         grass-user mailing list
>>         grass-user at lists.osgeo.org <mailto:grass-user at lists.osgeo.org>
>>         http://lists.osgeo.org/mailman/listinfo/grass-user
>>     _______________________________________________
>>     grass-user mailing list
>>     grass-user at lists.osgeo.org <mailto:grass-user at lists.osgeo.org>
>>     http://lists.osgeo.org/mailman/listinfo/grass-user

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20110218/fc66e992/attachment.html

More information about the grass-user mailing list