[GRASS-user] Install Addon GRASS 7.0 on Mac

William Kyngesburye woklist at kyngchaos.com
Wed Mar 2 11:38:01 EST 2011

On Mar 2, 2011, at 8:30 AM, Johannes Radinger wrote:

> -------- Original-Nachricht --------
>> Datum: Wed, 2 Mar 2011 15:14:24 +0100
>> Von: Markus Neteler <neteler at osgeo.org>
>> An: Johannes Radinger <JRadinger at gmx.at>
>> CC: kyngchaos at kyngchaos.com, grass-users at lists.osgeo.org
>> Betreff: Re: [GRASS-user] Install Addon GRASS 7.0 on Mac
>> On Wed, Mar 2, 2011 at 2:11 PM, Johannes Radinger <JRadinger at gmx.at>
>> wrote:
>>> Hello,
>>> first great thanks to you William! My GRASS 7.0 is no perfectly running
>>> on my Mac 10.6.6.
>>> Now I want to install the r.stream addon. I tried with
>>> g.extension extension=r.stream
>> svnurl=https://svn.osgeo.org/grass/grass-addons/grass7 prefix=$GRASS_ADDON_PATH
>>> but I failed...
>>> So what do I have to do?
>> Tell us why it fails :) I.e. send the error message...
> That's the error message I get:
> Checked out revision 45518.
> Compiling 'r.stream'...
> make: stat: /users/admin/downloads/grass-7.0.svn_src_snapsho
> t_2011_02_26/dist.i386-apple-darwin10.6.0: Permission denied
> mkdir: /users/admin/downloads/grass-7.0.svn_src_snapshot_201
> 1_02_26: Permission denied
> make: *** [/users/admin/downloads/grass-7.0.svn_src_snapshot
> _2011_02_26/dist.i386-apple-darwin10.6.0] Error 1
> ERROR: Compilation failed, sorry. Please check above error messages.
> mkdir -p /users/admin/downloads/grass-7.0.svn_src_snapshot_2011_02_26/dist.i386-apple-darwin10.6.0
> (Wed Mar  2 15:25:18 2011) Command finished (8 sec)
> Interestingly it mentions my download-directory where I compiled the grass-gis before... So is it not okay then to delete the downloaded source-snapshot after compiling and installing (at the moment it is still there).

I've never tried g.extension before.

That $GRASS_ADDON_PATH can have multiple paths in it, separated by : (colon).  The Mac startup does just this.  And it looks like g.extension doesn't handle this, so it's trying to create a bogus folder, though it should not be having permissions problem since it would still be in your home folder.  Maybe the : separator is confusing the system (some Mac internals still use the old : file path separator).

g.extension also changes how GRASS_ADDON_PATH is interpreted, from GRASS 6 - it used to be a direct path to the executable folder, ie bin/, now it's a path to the parent of that.  The default user addon paths set by the Mac startup are (GRASS version is major.minor version):

~/Library/GRASS/[GRASS version]/Modules/bin
/Library/GRASS/[GRASS version]/Modules/bin

I didn't catch the change and haven't updated the Mac startup yet.  Though it looks like the normal startup does both, which still gets it messed up.

So, I'd say set the prefix=~/Library/GRASS/7.0/Modules for g.extension, but GRASS would not find your installed extension afterwards to execute it.

William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>

The equator is so long, it could encircle the earth completely once.

More information about the grass-user mailing list