[GRASS-user] Using r.buffer on image with geographic coordinates

Ned Horning horning at amnh.org
Sun Mar 27 09:57:50 EDT 2011

Hi Markus,

Thanks for your help. I am trying to follow your instruction but ran 
into a problem compiling v.buffer. I used svn to download grass 6.5 into 
/usr/local/src and it appears to have compiled just fine and grass65 
seems to be working. To compile v.buffer I tried:
sudo make MODULE_TOPDIR=/usr/local/grass-6.5.svn/

from the /usr/local/src/grass6_devel/vector/v.buffer directory but that 
didn't work. I pasted the error message below.

I expect my MODULE_TOPDIR assignment is not correct. I'll try to figure 
out the problem tomorrow but if you know what the problem is please let 
me know.

Once I compile v.buffer do I have to do anything to deactivate v.buffer2?

Thanks again for the help.

nedhorning at ubuntu-laptop:/usr/local/src/grass6_devel/vector/v.buffer$ 
sudo make MODULE_TOPDIR=/usr/local/grass-6.5.svn/
/usr/local/grass-6.5.svn//include/Make/Module.make:25: warning: 
overriding commands for target `install'
/usr/local/grass-6.5.svn//include/Make/Rules.make:90: warning: ignoring 
old commands for target `install'
gcc -I/usr/local/grass-6.5.svn/dist.x86_64-unknown-linux-gnu/include -g 
-O2 -I/usr/include/gdal -DPACKAGE=\""grassmods"\" 
-I/usr/local/grass-6.5.svn/dist.x86_64-unknown-linux-gnu/include -o 
OBJ.x86_64-unknown-linux-gnu/main.o -c main.c
main.c: In function ‘main’:
main.c:274: error: ‘dist’ undeclared (first use in this function)
main.c:274: error: (Each undeclared identifier is reported only once
main.c:274: error: for each function it appears in.)
main.c:324: error: invalid type argument of ‘->’ (have ‘int’)
make: *** [OBJ.x86_64-unknown-linux-gnu/main.o] Error 1

On 03/26/2011 05:27 AM, Markus Neteler wrote:
> Hi Ned,
> On Fri, Mar 25, 2011 at 2:42 PM, Ned Horning<horning at amnh.org>  wrote:
>> Hi - I am trying to create buffers for large (~1GB) line and polygon vector
>> files. I tried v.buffer but after letting it run overnight with no apparent
>> progress I killed the process. I'm not aware of any software capable of
>> buffering large vector files on a modest computer so that wasn't a big
>> surprise.
> So we hope that there is still a chance to make GRASS the only one
> to suppor this :)
> Note that v.buffer is somewhat in transition:
> http://trac.osgeo.org/grass/ticket/699#comment:10
> "All these test cases are successfully completed by v.buffer/v.parallel;
> on confirmation by I would reactivate v.buffer/v.parallel and deactivate
> v.buffer2/v.parallel. For trunk that would mean that v.buffer which is
> actually v.buffer2 gets replaced with v.buffer, same for v.parallel.
> Markus M
> "
> and
> http://trac.osgeo.org/grass/ticket/699#comment:15
> If you can compile yourself, please try GRASS 6.5 from current SVN
> (or weekly snapshot) and go into
> vector/v.buffer/
> and compile this fixed older but apparently better version.
> If that then works ok for you, it will be another reason to reactivate
> the fixed original version of v.buffer rather than promoting the
> currently used v.buffer2.
> Markus

More information about the grass-user mailing list