[GRASS-user] Location deletes on restart

Daniel Lee lee at isi-solutions.org
Thu Nov 10 05:37:21 EST 2011

I also find it very odd.

2011/11/10 Hamish <hamish_b at yahoo.com>

> so it's fully reproducible?
So far, yes. I've reproduced it three times, sadly twice by accident.

> and the location still exists on the disk after you exit grass
> completely? (double check with `ps`, look for Init.sh)
I just tried it this time again. ps -A | grep Init.sh turns up with nothing.

> and it is gone directly after reboot? ie before grass is restarted
> after a boot?

> plenty of free disk space?

Several hundred GB.

> e2fsck comes up clean?

Never worked with e2fsck before and it looked a little dangerous when I
thumbed through the man page... Sadly, I'm kind of short on time today so I
can't read myself into it too much. What are you looking for exactly?

> ssd or traditional hard drive?

Normal, traditional hard drive.

> anything special about the
> partition? (it's not symlinked into /var/tmp/ or anything like
> that?)

> does running "sync" before shutting down help?
Tried it just now. Didn't make a difference.

> waiting >35 sec after shutting down grass before turning off the
> computer?
Had done that every time before... I shut down GRASS, then finished some
other projects, then turned off the computer so at least 20 minutes went by.

> grass itself doesn't go near the boot/shutdown init scripts
> so if it happens outside of grass I'm wondering what it could
> be..
Yes, it definitely is strange, because it's always the location I worked on

I should perhaps mention that I also have GRASS 7 compiled from source, and
I've worked with both versions on this machine before. However, the
phenomenon I'm talking about right now has occured with GRASS 6, I haven't
used 7 in at least three weeks.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20111110/7d72e54a/attachment.html

More information about the grass-user mailing list