[GRASS-user] Re: compiling grass65svn - error on ubuntu 11.10

Helmut Kudrnovsky hellik at web.de
Fri Nov 18 19:17:54 EST 2011

now tried with r49289 - grass/branches/develbranch_6

>> my configure line is:
>> myricaria at myricaria-hp-pavilion-ze4900-PJ920EA-ABD:/usr/local/src/grass/grass6_devel$
>> ./configure
>> --with-cxx
>> --with-sqlite
>>  --with-cairo
>> --with-freetype
>> --with-nls
>> --with-read-line
>> --with-gdal=/usr/bin/gdal-config
>> --with-python=/usr/bin/python2.7-config
>> --with-geos=/usr/bin/geos-config
>> --with-freetype-includes=/usr/include/freetype2/
>> --with-proj-share=/usr/share/proj
>> I'm getting following:
>> configure: error: can not run ./config.sub

now tried with

myricaria at myricaria-hp-pavilion-ze4900-PJ920EA-ABD:/usr/local/src/grass6_devel$
./configure --with-cxx --with-sqlite --with-cairo --with-freetype
--with-proj-share=/usr/share/proj --with-geos=/usr/bin/geos-config
--with-gdal=/usr/bin/gdal-config --with-tcltk-includes=/usr/include/tcl8.5
--with-wxwidgets=/usr/bin/wx-config --with-nls
configure: error: can not run ./config.sub

>Please post also the lines before that. 

there are no lines before. should there be any?

I'm following:


...which one of above would be the recommended?

>you need autoconf 2.13 (not 2.65) but both can be installed in parallel. 

here are following autoconf-versions on the system

autoconfig 2.68-1ubuntu1 (oneiric)
autoconfig 2.13-60 (oneiric)

all the best

View this message in context: http://osgeo-org.1803224.n2.nabble.com/compiling-grass65svn-error-on-ubuntu-11-10-tp6967393p7010258.html
Sent from the Grass - Users mailing list archive at Nabble.com.

More information about the grass-user mailing list