[GRASS-user] wx digitiser destroyed my vector again

Shane Litherland litherland-farm at bigpond.com
Sun Nov 20 10:09:21 EST 2011

Hi all,

just had an unsavoury experience for the second time since using wxgui
in 6.4.2RC1

when digitising a vector that consisted of boundaries and centroids, I
was attempting to split a boundary to add more adjacent
boundaries/centroids. somewhere in process of trying/learning to get the
break/split/similar tools to work, then moving boundary segments to tidy
up mistakes and/or using undo button, everything in the vector except
for a handful of boundaries that were in view of the gui vanished. It
seemed to become apparent at the point of hitting the 'undo' button. I
didn't save anything just quit GRASS and reopened, but that's how it

had to restore vector file from a backup and re-do any recent stuff I'd

am i using some of these tools wrong or does GRASS wx digitiser have
some serious issues when it comes to data integrity? i thought i'd
figured enough out to safely use the wx digitiser but if i have to keep
restoring from backups every couple of weeks i might be better off going
back to the v.digit option...??

a bit further into things, i've now had GRASS crash when trying to split
and delete centroids or boundary vertices. I re-opened GRASS with
relevant vector, went to digitise and got 'topology needs to be rebuilt'
message but when I chose to rebuild it crashed GRASS again. I have now
re-opened GRASS four times and tried to rebuild topology from the
message and it keeps crashing.
I tried rebuilding with v.build and it seemed to work but told me I had
more boundaries with errors than i expected, then tried to open up
vector to digitise (wxgui) and it still crashed.
I had to re-recover the vector from my backup, and use v.digit (tcl/tk)
digitiser to check over things.
only when i'd removed the aberrant boundaries (in tcl/tk) that had
resulted from me splitting/moving sections, could I get it to build
without reporting any boundaries with errors, and not crashing in the
wxgui digitiser.

I later found two tables connected to this vector had been deleted from
postgresql! I did a force remove (using wxgui) of the faulty vector
before restoring from my backup, but i have used force remove many times
prior to 6.4.2RC1 without it deleting tables... so has something changed
here, or did the tables get deleted somewhere in the mess that resulted
with the wx digitiser...???

This kind of stuff is bloody annoying... what was 15 minutes work has
now taken me 3 or more hours up late fixing the mistakes/errors... If
i'm doing something wrong i'd be most appreciative of being corrected,
if GRASS is misbehaving then i'd appreciate suggestions on what part of
my experience to document in a bug report. in the meantime, looks like
i'll go back to using the tcltk digitiser even though the wx one is a
bit fancier... i'd prefer stable data over latest fashions any day!

too tired tonight to dig up specs on my wx, python, etc but using ubuntu
10.04.3 mostly from standard repositories for updates etc. can get more
info if required.



More information about the grass-user mailing list