[GRASS-user] d.vect dialog issues, and query tool issues (previously: GRASS GUI issues)

Shane Litherland litherland-farm at bigpond.com
Sat Oct 8 21:09:40 EDT 2011

Hi all,

With all quiet on the users emails on my subject, I went web-searching
and found some leads: The ubuntu desktop themes seemed to have an issue
reported for a range of programs that the GNOME/gtk settings needed
hacking/tweaking, see

I followed the info therein, and have just run GRASS again with wxpython

The outcome is partially successful in that when choosing the query tool
in map display, I can click on the map and not get the previously posted
error in the terminal (I launch grass from terminal / command line).

But I am only partly getting what I expected from the query tool. When I
choose the option for "display mode" and click on a point in active
layer, the 'Abort Command' button in Command Console tab briefly
activates then returns to being inactive but nothing actually
happens/shows in the console.

When I choose the "edit mode" for the query tool and click on a
point/line/etc that I know has a db connection ONLY for layer one, it
brings up a dialog box with details from the relevant table that the
point/line/etc is linked to. If I click on something that I know has
connections for both layer one and layer two, the query tool even in
edit mode doesn't return anything. If I change

The more serious issue of GRASS freezing if I use the d.vect dialog is
still happening. several examples of what happens:

-open GRASS from terminal then open a saved workspace (OK)
-right-click on any vector layer in 'Map Layers' tab, choose properties,
and the d.vect dialog box shows (OK)
-if I do not change any settings in the dialog box, I can continue to
right-click and display the d.vect dialog for any of the vector layers,
as many times as I like without causing a freeze (OK)
-I then started working my way down the vectors listed in 'map layers'
-first vector, changed 'Selection - Layer number' to '2', hit OK button,
and map display window updates accordingly to show only the points with
db entries for layer 2 (OK)
-second vector, changed 'Colours - line colour' (OK)
-third vector, changed 'Selection - feature type' and unchecked
'centroid' (OK)
-returned to second vector, changed colour again (OK)
-returned to third vector, and right-click>properties results in the
d.vect dialog opening with a blank window instead of all the tabs and
settings. Clicking on the close icon then gives the 'system busy' msg
and I have to force-quit which closes all the GRASS GUI's.

-in a fresh start of the GUI, I repeated this and did not get a freeze
on the last step above, I could change the 'feature type' to re-display
-I then continued and went back to vector two, changed colour again (OK)
-back to vector 3, unchecked 'centroids' again (OK)
-back to vector 3, try to re-check 'centroids' but got blank d.vect

another fresh start and I did this:
-vector one, change layers to 2 (OK)
-vector two, change colour (OK)
-click on all vectors numerous times to view d.vect but close dialog
each time with no changes (OK)
-vector three, deselect 'centroids' (OK)
-vector one, change layers to -1 (OK)
-vector one, change layers to 2 (OK)
-vector one, change layers back again to -1 (OK)
-vector two, change colour again (OK)
-vector two, try to change colour yet again, get blank d.vect dialog

another fresh start;
-vector two, change colour (OK)
-vector three, deselect centroids (OK)
-vector two, change colour again(OK)
-vector three, select centroids again (OK)
-vector three, change line colour (OK)
-vector three, change line colour back again (OK)
-vector one, add cat criteria '>10' (OK)
-vector one, add cat criteria '5' (OK)
-vector one, remove cat critera and 'apply', change layers to 2 and
'apply, then change fill colour and 'OK' (i.e. closes dialog) (OK)
-vector one, view the d.vect dialog but just close it again no changes
-vector two, change colour (OK)
-vector two, view d.vect dialog but close no changes (OK)
-vector three, d.vect opens with blank dialog.

upon force-closing after this example, the terminal had the message:
(office:5204): Pango-CRITICAL **: pango_layout_get_cursor_pos: assertion
`index >= 0 && index <= layout->length' failed

(office:5204): Pango-CRITICAL **: pango_layout_get_cursor_pos: assertion
`index >= 0 && index <= layout->length' failed

a shorter scenario from fresh start:
-vector three, deselect centroids  (OK)
-vector one, select layer two (OK)
-vector three, re-select centroids (OK)
-vector one, get blank d.vect

repeating this scenario, I only got to the third point where the GUI
closed again and gave terminal message:
(office:5675): Gdk-WARNING **: XID collision, trouble ahead

(office:5675): Gdk-WARNING **: XID collision, trouble ahead

(office:5675): Gdk-WARNING **: XID collision, trouble ahead
office: Fatal IO error 0 (Success) on X server :0.0.

repeating it again, I got to step 3 and a blank d.vect dialog appeared.

repeating it yet again, I got past step 3, and could continue to
-vector one, change layers back to -1 (OK)
-vector two, change symbol size (OK)
-vector two, change line width (OK)
-vector one, change layers to 2 again (OK)
-vector one, change colours (OK)
-vector two, change line width again (OK)
-vector one, change colours again )OK)
-vector one, change layers to -1 again )OK)
-vector two, change colour (OK)
-vector one, enter criteria for cats - did it four or 5 times...although
my syntax seemed to not be right, Display wasn't showing the points I
expected for e.g entering single values for a cat, typing 5-9, typing
6,7,8,9 , typing <10 and then when I tried typing >10 the GUI closed
again, error message "Pango-Critical" as per above.

tried a fresh start, to check those cat syntax...
-only go to vector one,
-enter in cat criteria '5-9 and hit 'apply' (i.e. d.vect dialog still
this correctly displayed on the map the five points I was expecting
-enter cat criteria 5,6,7,8,9 and displayed OK
-enter cat criteria <10 or >10 displayed nothing but at least it didn't
lock up or close the GRASS GUI like previously
-enter cat criteria 2-9 and displayed OK
-left those cat criteria in, and hit 'OK' to close dialog
-open dialog again and remove criteria (OK)
-vector two, change colour (OK)
-vector one, cat criteria 2-9, still working! (OK)
-vector two, change colour again (OK)
-vector one, remove cat conditions (OK)
-vector four, deselect centroid, change colour (OK)
-vector one, cat critera 5-9 (OK)
-vector one, remove cat critera, select layer two (OK)
-vector four, get blank d.vect dialog

One other event when trying different combos of above steps, where I
didn't even get a blank d.vect dialog, the whole GRASS GUI closed itself
and the terminal showed this message (note 'office' is

The program 'office' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadDrawable (invalid Pixmap or Window parameter)'.
  (Details: serial 233034 error_code 9 request_code 70 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()

one final scenario that is a little different, from fresh start of GUI:

-open workspace (OK)
-vector one, change layers displayed, a couple of times (OK)
-add another vector, change layers displayed (OK)
-return to vector one, open d.vect and this time the info/tabs are
displayed in the dialog, but a mouse-click on e.g. layer number, does
nothing. after a few seconds, the dialog greys-out and the force-quit
process is required. So the end result is the same, but in the dying
stages at least the d.vect dialog was showing something as opposed to
all previous cases where it was a blank box. 

I cannot see any consistency on what might be causing this lock-up... it
does seems to require display changes to be made on more than one
vector, and for the d.vect dialog to then be opened at least a second
time on one of the vectors that have been changed. Apart from that, it
seems somewhat haphazard in its occurrence.

I will continue to work with the tcltk GUI until I find out more about
if this issue can be, or is, fixed. Anyone dedicated enough to follow
this up, if you do want me to test other certain steps or provide more
details on my setup, let me know :-)


More information about the grass-user mailing list