[GRASS-user] GRASS and GRASS-DEV Package

Hamish hamish_b at yahoo.com
Wed Sep 21 19:45:14 EDT 2011

Solimyr wrote:
> I have GRASS 6.4.1 and Ubuntu 10.10 (Maverick).
> I want to install an addons called 'r.seg'. I have tried to
> install this via SVN but I doesn't work. After various google
> research, I've understand that I don't have grass-dev package
> installed!I have searched around but didn't found anything,
> just this:
> http://packages.ubuntu.com/maverick/grass-dev
> http://packages.ubuntu.com/maverick/grass-dev 
> I've tried to install but is not compatible!Can't install!
> Do you know where I can find the grass-dev package for my
> GRASS and Ubuntu version?

just open a terminal and run:

  sudo apt-get install grass-dev

but it is broken right now; unless you are a Makefile guru you
need the full grass source code if you want to compile GRASS
addons in Ubuntu currently.

If it were a python or shell script you could just copy the
script into the right place and make it executable, but as r.seg
is a C program it will need to be compiled.

In the last few days I have been working on fixing this in the
DebianGIS package building rules and the g.extension(.sh) script
and am very very close to having it function properly there, docs
and all.  (and thus for future ubuntus too)

@devs: current problem is that Grass.make's INST_NOW=y works,
but wants to run "make" a second time. the first time it all
builds ok in the user's .tmp dir, but the (unneeded?!) 2nd pass
it breaks looking for /usr/.../dist.x86_64-unknown-linux-gnu/
which it doesn't have permission to create/write to.

> One more stupid thing; If I install an addons on GRASS,
> after that, can I use the same on the GRASS Plugin in QGIS?

yes, but not automatically. You need to write a .qgm file and
stash it in the right place. The only grass addon which has that
support AFAIK is v.surf.icw, although I haven't tested with a
modern version of QGIS.


More information about the grass-user mailing list