[GRASS-user] GRASS GUI issues

Shane Litherland litherland-farm at bigpond.com
Fri Sep 30 21:57:17 EDT 2011

Hi all,

I had GRASS 6.4.0 from stable rep's for ubuntu lucid 64-bit, and it was
freezing when I opened the properties dialog for a vector layer. Worked
OK the first time I used it for a layer, but if I tried going back to
change things, everything just 'greyed out' and even after leaving it
for a cup of tea, it was still stuck. Tried to close the offending box
(d.vect dialog), got msg that it was busy etc, chose to force quit which
closed GRASS entirely.

So I checked what was currently stable on the GRASS site, i.e. 6.4.1
(available from the unstable ubuntu rep's)

It may have gotten rid of the freezing issue, I'm still checking it out.
But in the process of checking it out, I tried to change to the command
tab in main window and each time I click on the tab, the following
message came up in the terminal:

(python:1736): CRITICAL **: murrine_style_draw_box: assertion `height >=
-1' failed

Nothing seemed to show in the GRASS command tab.

I noted on re-starting GRASS, I was getting same msg but different
python: number at start.

Also got same msg if I went to the map display and chose the 'query'
tool. when I clicked on the map, above msg occured multiple times
(possibly same multiples as object had connections to db tables?)

On top of this, the original problem of d.vect dialog freezing, is still
happening. e.g. first time I opened it to type in a criteria in 'where'
box, seemed OK (apart from the map display not showing anything and I'm
fairly sure my sql was OK). Second time opening it to try removing the
sql, it froze.

Before I venture into the world of bug reporting for GRASS, thought I'd
check with user group in case it's something I've mucked up...? or
something already known about? 


More information about the grass-user mailing list