Daniel Lee lee at isi-solutions.org
Fri Dec 7 02:38:04 PST 2012

Dear list,

I'm working on a server that unfortunately does not have GRASS installed on
it. In order to work on my large amounts of data there, I've mounted the
external file system with ssh using SSHFS. This works fine and I can read
and write data without problems.

I've made a GRASS location on that server, which also worked fine, and
creating all of the locations and mapsets using the GRASS GUI worked
without a hitch. But every time I try to perform any command within a
mapset, I get the following error:

ERROR: MAPSET PERMANENT - permission denied

It doesn't matter what the command is (g.region, g.list, g.gui) or whether
the mapset is PERMANENT or another. I can create the mapsets, I just can't
work in them.

Just as an experiment, I changed the rights for the GRASS DB on the server
to 777 recursively (there's nothing in there anyway since I can't do
anything on it). This doesn't make a difference, though.

Anybody know what the problem could be?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20121207/9610b2e1/attachment.html>

More information about the grass-user mailing list