Markus Neteler neteler at osgeo.org
Sun Dec 9 09:46:32 PST 2012

Hi Daniel,

On Fri, Dec 7, 2012 at 11:38 AM, Daniel Lee <lee at isi-solutions.org> wrote:
> Dear list,
> I'm working on a server that unfortunately does not have GRASS installed on
> it. In order to work on my large amounts of data there, I've mounted the
> external file system with ssh using SSHFS. This works fine and I can read
> and write data without problems.

(yes, did the same several times)

> I've made a GRASS location on that server, which also worked fine, and
> creating all of the locations and mapsets using the GRASS GUI worked without
> a hitch. But every time I try to perform any command within a mapset, I get
> the following error:
> ERROR: MAPSET PERMANENT - permission denied
> It doesn't matter what the command is (g.region, g.list, g.gui) or whether
> the mapset is PERMANENT or another. I can create the mapsets, I just can't
> work in them.

So, "touch /wherever/sshfs/grassloc/PERMANENT/blafile.txt" would work?

> Just as an experiment, I changed the rights for the GRASS DB on the server
> to 777 recursively (there's nothing in there anyway since I can't do
> anything on it). This doesn't make a difference, though.
> Anybody know what the problem could be?

Yet unclear to me. Could you send the permission list (ls -la) of the
parent directory?


More information about the grass-user mailing list