[GRASS-user] installing addons grass 6.4.3svn-ubuntu 11.10

ciskoh matteo.jriva at gmail.com
Thu Feb 23 10:11:43 EST 2012

Hi all,
I know this is quite a recurrent topic, but I couldn't find any solution on
my own.

Problem is I need to install grass addon r.viewshed.
I run Grass 6.4.3svn from http://ppa.launchpad.net/grass/grass-stable/ubuntu
on ubuntu 11.10 (virtualised on a macbook, but that shouldn't be an issue).
And I've installed grass-dev


I've tried it with:
 g.extension r.viewshed

and the result was a huge output (Ill post the whole thing if required) that
ended with:

sh: Can't open /usr/lib/grass64/tools/g.html2man
make[2]: ***
Error 127
make[2]: Leaving directory
make[1]: *** [mancmd] Error 2
make[1]: Leaving directory
make: *** [default] Error 2
ERROR: Compilation failed, sorry. Please check above error messages.

2) Then I tried with the GUi (Settings>>Install extension from add-ons)
which I believe calls g.extension.py and a an error pop-up shows up:

Traceback (most recent call last):
  File "/usr/lib/grass64/etc/gui/scripts/g.extension.py", line 802, in
  File "/usr/lib/grass64/etc/gui/scripts/g.extension.py", line 767, in main
  File "/usr/lib/grass64/etc/gui/scripts/g.extension.py", line 179, in
    url = "http://grass.osgeo.org/addons/grass%s/modules.xml" %
KeyError: 'version'

Then I tried the two procedures described 

if I go into /grass64/bin/r.viewshed/ folder and I type make
MODULE_TOPDIR=/usr/lib/grass64 I get:

Makefile:8: /usr/local/grass64/include/Make/Module.make: No such file or
make: *** No rule to make target
`/usr/local/grass64/include/Make/Module.make'.  Stop.

If I go for  "sudo make" I get:

../..//include/Make/Module.make:25: warning: overriding commands for target
../..//include/Make/Rules.make:90: warning: ignoring old commands for target
Makefile:50: warning: overriding commands for target
../..//include/Make/Module.make:15: warning: ignoring old commands for
target `/usr/lib/grass64/bin/r.viewshed'
g++ -L/usr/lib/grass64/lib -Wl,-Bsymbolic-functions -Wl,--export-dynamic
-Wl,-rpath-link,/usr/lib/grass64/lib   -o /usr/lib/grass64/bin/r.viewshed
OBJ.i686-pc-linux-gnu/main.o OBJ.i686-pc-linux-gnu/distribute.o
OBJ.i686-pc-linux-gnu/eventlist.o OBJ.i686-pc-linux-gnu/grid.o
OBJ.i686-pc-linux-gnu/grass.o OBJ.i686-pc-linux-gnu/viewshed.o
OBJ.i686-pc-linux-gnu/rbbst.o OBJ.i686-pc-linux-gnu/statusstructure.o
OBJ.i686-pc-linux-gnu/visibility.o -lgrass_gis.6.4.3svn
-lgrass_datetime.6.4.3svn -lz     -lgrass_iostream.6.4.3svn
/usr/bin/ld: cannot open output file /usr/lib/grass64/bin/r.viewshed: Is a
collect2: ld returned 1 exit status
make: *** [/usr/lib/grass64/bin/r.viewshed] Error 1

SO right now I'm out of solutions, could somenone guide me through this
f***** addons installation?


View this message in context: http://osgeo-org.1560.n6.nabble.com/installing-addons-grass-6-4-3svn-ubuntu-11-10-tp4498897p4498897.html
Sent from the Grass - Users mailing list archive at Nabble.com.

More information about the grass-user mailing list