[GRASS-user] GRASS on Mac OS 10.8.3

Adam Dershowitz adershowitz at exponent.com
Tue Apr 9 09:23:55 PDT 2013

I figured out the problem and a temporary work around, that I figured I would let people know.  But, if anyone has  a better solution, I would love to hear it.
The problem seems to be that I have macports installed, and there appears to be an issue with python versions, and where it is being found.

I first tried using the acceptable macports way of changing to different versions of python, but these didn't help:
sudo port select python python26
sudo port select python python27-apple
Etc, but these didn't allow either 6.4 or 7.0 to run.

But, if I get rid of all my macports stuff by doing:
Sudo mv /opt/local /opt/local_tmp
Then I can open either GRASS 6.4 or 7.0.  I can then move opt/local back and then either GRASS seems to work fine.  Even if I quit and restart the gui they are fine.
This was not a problem for me on OS 10.6 and earlier.  So, something is different about search paths and/or environmental variables.
Renaming like that is not a viable long term solution, as I need macports stuff a bunch.  Any suggestions about how the application is searching and why it is not finding a good version?  Or maybe the real problem is that I don't have the correct port (or version) of something installed in Macports, and if I do then it might be that the macports version is fine, and would work.  I believe that there might have been a change between 10.6 and 10.8 related to 32 bit versus 64 bit being default builds, so could there be an issue with which version of wx, or some other library is being searched for?

Any thoughts or guidance?

-- Adam

From: Adam Dershowitz <adershowitz at exponent.com<mailto:adershowitz at exponent.com>>
Date: Monday, April 8, 2013 4:59 PM
To: "grass-user at lists.osgeo.org<mailto:grass-user at lists.osgeo.org>" <grass-user at lists.osgeo.org<mailto:grass-user at lists.osgeo.org>>
Subject: GRASS on Mac OS 10.8.3

I recently upgrade to a  new machine that has mac OS 10.8.3 on it (from 10.6).  Now, GRASS seems not to be working.  What's the status of GRASS on 10.8.3?
Here are the details.

I tried kyngchaos binary 6.4.2 and if I double click on it, I initially get:

 '/Applications/GRASS-6.4.app/Contents/MacOS/grass.sh'; exit
Rebuilding Addon HTML manual pages index...
Rebuilding Addon menu...
dyld: DYLD_ environment variables being ignored because main executable (/usr/bin/osascript) is code signed with entitlements
Python 2.6.8 found.

WELCOME TO GRASS              Version 6.4.2         2012

   1) Have at your side all available GRASS tutorials

   2) When working on your location, the following materials
      are extremely useful:
      - A topo map of your area
      - Current catalog of available computer maps

   3) Check the GRASS webpages for feedback mailinglists and more:

Hit RETURN to continue

If I then hit return I get:

Starting GRASS ...
Traceback (most recent call last):
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/wxpython/gis_set.py", line 35, in <module>
    from gui_modules import globalvar
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/wxpython/gui_modules/globalvar.py", line 76, in <module>
    import wx
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/__init__.py", line 45, in <module>
    from wx._core import *
  File "/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/_core.py", line 4, in <module>
    import _core_
ImportError: dlopen(/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/_core_.so, 2): no suitable image found.  Did find:
/Applications/GRASS-6.4.app/Contents/MacOS/etc/python/wx/_core_.so: mach-o, but wrong architecture
Error in GUI startup. If necessary, please
report this error to the GRASS developers.
Switching to text mode now.
Hit RETURN to continue...

I then tried downloading the newest 7.0 from cmbarton and ran into similar problems.  Any thoughts or suggestions?

Thanks much.

-- Adam

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/grass-user/attachments/20130409/c3c78e2a/attachment.html>

More information about the grass-user mailing list